Assim que criei o módulo de frete na primeira versão, que pode ser encontrada no forum do Magento, recebi reclamações solicitando a alteração do fopen para CURL devido a incompatibilidade com certos servidores.

Lancei a versão 2 com tracking e utilizando o CURL no lugar do fopen, novamente tiveram pessoas com incompatibilidade.

Tentando solucionar o problema de todos, estou disponibilizando a versão 2.1 agora utilizando a biblioteca do framework do Magento, ZendHttpClient que, na teoria, irá resolver o problema de incompatibilidade.

Use o Magento Connect para baixar a última versão.

Para quem já utiliza a versão 2, basta seguir os passos:

  • Copie o arquivo /app/code/community/Correio/Shipping/Model/Carrier/CorreioPost.php e cole no mesmo local da sua instalação Magento.
  • Após sobrescrever, a atualização está pronta e você estará usando a versão 2.1 agora utilizando Zend_Http_Client.

Espero que todos possam utilizar o módulo sem problemas.

Caso tenham problemas, sugestões ou até elogíos, postem um comentário que responderei com prazer.

Abraços e bons e-negócios!

© 2016. All Rights Reserved.

Proudly published with Ghost and Ghostium